
 
 

GIS TUTORIAL 3: Simple Geospatial Analysis with QGIS 

In this tutorial we will be learning some simple geospatial analyses related to elevation and 
hydrology with QGIS. This will help us to learn more about our sites. We will be using data from 
the database as well as data that we download from the internet. 

 

1 Sourcing Elevation and Hydrological Data (video tutorial playlist) 

We are going to find and download elevation and hydrological data and display it alongside 
data from the database in QGIS. 

1.1 Preparing EAMENA data for analysis in QGIS (video tutorial) 

Before we download any other data, we first need to open and prepare some EAMENA data for 
analysis in QGIS. Before that, we are going to add the NaturalEarth country shapefile that we 
have already downloaded into QGIS. 

 Use the Open Data Source Manager button on the Toolbar to add the NaturalEarth 
country data to your map. 

 

 Export some data as a shapefile from the EAMENA website for your area of interest. 
o Refer to Tutorial 19: Exporting from the Database for detailed instructions 

how to do this. 
o For this tutorial we will use an export of all the Roman period sites in Lebanon. 



 
 

o Add this data to QGIS using the Data Source Manager 

 



 
 

You are likely to have a combination of polygon, line and point data when exporting from the 
EAMENA database. We need to convert all our data into point data so that we can easily work 
with it in a single file. 

 Click on the polygon file in the Layers Panel 
 On the Menu go to “Vector” > “Geometry Tools” > “Centroids…” 

 

 Make sure that the polygon layer is selected and click “Run” 

 



 
 

A new “Centroids” point layer will be created above the polygon layer, appearing as a point in 
the centre of each polygon. 

 

 Repeat this process for your line and point shapefile data  

Although it may seem strange, we do need to do this for the points layer too, this is in case one 
site has more than one point in the shapefile. 



 
 

You will end up with three “Centroids” point layers above each of your original EAMENA 
shapefiles. 

 

These now need to be combined into a single point shapefile. 

 On the Menu click “Vector” > “Data Management Tools” > “Merge Vector Layers…” 

 



 
 

 Click the “Browse” […] button next to “Input layers” and tick the three “Centroids” layers 
and click “OK”. 

 

 Click the “Browse” […] button next to “Merged” and “Save to File…” and give the merged 
file a name in your suitable folder within your GIS folder. 

 Click “Run” and then “Close” when it has finished. 

 



 
 

You will now see your new merged layer in the Layers Panel and, when you move it to the top, 
covering every site in the Map View Window. 

 

We can now remove all of the old layers that we do not need. 

 Press and hold the [Ctrl] key on your keyboard (or [cmd] if you are using a Mac) and 
click all the old shapefile and centroid layers. 

 Right-click one of these layers while holding [Ctrl] and click “Remove layer”. 

 



 
 

You will be left with just your merged point layer and the country data. 

 

  



 
 

1.2 Downloading and adding elevation data (video tutorial) 

Now that we have our EAMENA site data ready to analyse, we are ready to download and add 
some elevation data to our map. 

 In your internet browser go to https://portal.opentopography.org/datasets 

 

 On the map zoom into your area of interest 
 Click “SELECT A REGION” and click and drag on the map to create an area of interest 

 

https://portal.opentopography.org/datasets


 
 

 Scroll down on the page and click “Global Data”, and then “SRTM GL1” 

 

 Scroll down and under “3. Visualisation” untick “Generate hillshade images…” 
 Scroll down and give the task a name – e.g. “Lebanon_SRTM” 
 Type your email address and click “Submit” 

 



 
 

You will see a screen informing you that your data is being processed. 

 When the task completes click on the “rasters_srtm.tar.gz” file to download it. 

 

 When the download completes move this file into a suitable folder within your GIS 
folder 

 Right-click the file and select “7-Zip” > “Extract Here”, creating a new “rasters_srtm.tar” 
file. 

 

 Use 7-Zip to extract this file too (it is double-zipped), creating a new “output_srtm” file 



 
 

 In QGIS use the Open Date Source Manager to add this to your map 

 

You now have elevation data for your area of interest. 

 

 



 
 

1.3 Visualising elevation data (video tutorial) 

Now that we have added the elevation data to our map, we can now make it easier to read and 
more attractive. 

First, we need to change the coordinate reference system (CRS) of the elevation data and our 
site data. 

 Press the CRS button at the bottom right of the screen 

 

 Type in the UTM zone for your area of interest (e.g. 36N). 
o If you do not know it, you can find it here 

https://mangomap.com/robertyoung/maps/69585/what-utm-zone-am-i-in-# 
 Scroll down until you see the option with “WGS 84 / UTM zone [your zone e.g. 36N]”, 

click on this and Apply and OK. 

 

https://mangomap.com/robertyoung/maps/69585/what-utm-zone-am-i-in-


 
 

 In the Layers Panel, right-click the SRTM raster and select “Export” > “Save As”. 

 

 Click the Browse button […] next to “File name” and save your new file in your 
“Geospatial” folder with a new name e.g. “SRTM_Lebanon_UTM”. 

 



 
 

 Change “CRS” to “Project CRS” and make sure that this matches the UTM Zone you have 
just chosen for the entire map. 

 

You should now have your new SRTM raster in the Layers Panel. 

 Remove the old one by right-clicking “output_srtm” and selecting “Remove layer” 



 
 

Now we are going to change the symbology of our new SRTM raster. 

 Right-click your new raster in the Layers Panel and select “Properties”. 
 Click on the symbology tab. 
 Change “Render type” from “Singleband gray” to “Singleband pseudocolour”. 
 Click the black arrow next to “Color ramp”. 
 Click “All Color Ramps” to see more options and click to select the one you want. 

 

 You can reverse the colours by clicking the arrow again and selecting “Invert ramp” 

  



 
 

 You can also find more options (including ones specifically designed for topography) by 
clicking “Create new ramp” > “Catalog: cpt-city”. 

 



 
 

Once we are happy with the colours, we are going to create a second layer that provides some 
added detail. 

 On the Menu click Raster > Analysis > Hillshade. 
 In the new window make sure that your UTM raster is selected and then scroll down to 

“Hillshade”. 
 Click the Browse button […] and select “Save to File…”. 
 Navigate to your Geospatial folder and save your new raster as “Hillshade”. 
 Click Run and then Close when it has finished. 

 



 
 

Your new “Hillshade” raster will appear in the Layers Panel and in the Map View 

 

We are going to combine this with the colourful SRTM raster by making it partially transparent. 

 Right-click your hillshade raster in the Layers Panel and select “Properties”. 
 Click on the “Transparency” tab. 
 Use the slider to change the Global Opacity to approximately 50%, click Apply and OK. 

 



 
 

As long as your Hillshade raster is above your SRTM raster in the Layers Panel, you should now 
be able to see added relief detail, creating a much more attractive map. 

 

1.4 Adding hydrological data (video tutorial) 

As well as elevation data, we can also obtain hydrological data from the internet to further 
improve our map. 

 On your internet browser visit the HydroSHEDS website 
https://hydrosheds.org/page/hydrorivers 

This website contains river, lake and basin data that is available to download for free. You can 
download data by region or for the entire globe.  

 For most of the Middle East you need the Europe dataset. 
 For North Africa you need the Africa dataset. 
 Scroll down to “Shapefiles” and click the “Download” button next to Europe or Africa 

  

https://hydrosheds.org/page/hydrorivers


 
 

 Click “Download” again on the new page that opens. 

 

 Allow the zip file to finish downloading. When it is done, move it into your 
“GIS/Geospatial” folder. 

 Right-click the file and select “7-Zip” > “Extract Here” (or another un-archiver program). 
 In QGIS use the Open Data Source Manager button to add the new shapefile inside the 

folder. 

 



 
 

We could make all the rivers look the same, but it would be better to show their relative size. 

 Right click the HydroRIVERS shapefile and select “Properties”. 
 Click on the Symbology tab. 
 Change “Single Symbol” to “Graduated”. 
 Change “Value” to “UPLAND_SKM”. 
 Change the Colour ramp to a suitable blue one. 
 Click the “Classify” button then Apply and OK. 

 

The rivers will now have a different shade depending on the size of their catchment area. 

 



 
 

PRACTICE: create a topographical map of your area of interest using this data. 

 

 

 

  



 
 

2 Elevation and Hydrological Geospatial Analysis (video tutorial playlist) 

Having downloaded the elevation and hydrological data that we need from the internet, we are 
now going to use it to carry out some simple geospatial analysis in order to find out more about 
our sites. We are going to calculate the elevation of all of our sites and how far they are from the 
nearest watercourse. 

2.1 Extracting elevation values (video tutorial) 

It is possible to read the elevation values of any particular area, including for our sites. 

 On the Toolbar click the Identify Features button. 
 Turn off the Hillshade layer and then click anywhere on the SRTM raster. 

The Identify Results Panel will open and next to “Band 1” you will see the elevation of the pixel 
that you clicked on. 

 

 Find one of your sites and click on it using the “Identify Features” button 



 
 

You will see lots of information about your site from the database. 

 Scroll down in the results and at the bottom you will see your SRTM raster. 
 Expand this twice and you will see the elevation value for the site. 

 



 
 

It would take a long time to do this and record the result for every site, so there is also an 
automatic way of achieving this in QGIS. 

 Click “Processing” on the Menu and select “Toolbox”. 
 Expand “Raster analysis” and double-click on “Sample raster values”. 

 



 
 

 For “Input point layer” select your sites. 
 For “Raster Layer to sample” select the SRTM raster. 
 For “Output column prefix” type “Elevation”. 
 For “Sampled points” click the Browse button […] and “Save to File”. 
 Give your new shapefile a name and click “Save”. 
 Click Run and then Close when it completes. 

 

Your new shapefile will be added to your Map View and Layers Panel. 

 Right-click it and select “Open Attribute Table” 
 Scroll to the last column on the right 

You will see that a new “Elevation” column has been added and the elevation of each site has 
been calculated. 

 



 
 

We can show this information on the map in a similar way to how we symbolised the rivers. 

 Right-click your new sites shapefile and select “Properties”. 
 Click on the Symbology tab and change “Single symbol” to “Graduated”. 
 Change “Value” to “Elevation”. 
 Pick a colour ramp that you like. 
 Click “Classify” and then Apply and OK. 

 

Your sites will now be coloured according to their elevation. 

 

 Remove the old shapefile from the Layers Panel by right-clicking and selecting “Remove 
layer” 



 
 

2.2 Measuring distance (video tutorial) 

In a similar way, it is possible to measure the distance between features in QGIS, for example the 
distance between our sites and the nearest river. 

 On the Toolbar click the Measure Line button. 
 Click between any two points on the map to measure the distance between them. 
 You can also change the units if this is helpful. 

 



 
 

You could use this to measure the distance between two sites, or between a site and the nearest 
river. 

 Zoom into a site and its nearest river. 
 Click the Measure Line button and then click on the site and the nearest section of the 

river. 

 

 

This will measure the distance between the site and the river. Just like with the elevation task, 
there is a way that we can automate this for every site.  



 
 

First, we must make sure that all our relevant data is in UTM format so that distances are 
measured in metres rather than decimal degrees. 

 Right-click your sites shapefile and select “Export” > “Save Sites As”. 
 Make sure “Format” is “ESRI Shapefile”. 
 Under “File name” click the Browse button […] and save a new version of your file. 
 For “CRS” select “Project CRS”, making sure that this is your UTM zone. 
 Everything else can stay the same, so click OK. 

 



 
 

A new version of your file will be added to the Layers Panel and the Map View. However, it will 
have very basic formatting, so we are going to copy and paste the symbology from the old file 
before we remove it from the map. 

 Right-click your old shapefile and select “Styles” > “Copy Style” > “All Style Categories”. 
 Right-click your new shapefile and select “Styles” > “Paste Style” > “All Style Categories”. 

 

Your new shapefile should now look identical to the old one, so you can now remove the old file. 

 



 
 

Now we need to do something similar with the HydroRIVERS shapefile. However, in order to 
speed up the automatic measuring step, we are also going to just extract part of the file to make 
it smaller. 

 In the Map View, zoom in to the area that you want to trim the rivers shapefile to. 
o The easiest way of doing this for your area of interest is to “Zoom to Layer” on 

your SRTM raster. 
 Open the HydroRIVERS Attribute Table. 
 Click the “Show All Features” filter button and select “Show Features Visible on Map”. 
 Click the row number on the left side next to the first feature at the top of the table. 
 Scroll down to the bottom, hold the shift key and click the row number next to the last 

feature to select all of the visible features. 

 



 
 

 Close the Attribute Table. 
 Right-click the shapefile in the Layers Panel and select “Export” > “Save Selected 

Features”. 
 For “Format” select “ESRI Shapefile”. 
 Click the Browse button […] and give the new shapefile a name. 
 Make sure that for “CRS”, you have selected “Project CRS” and that this matches your 

UTM zone. 
 Click OK. 

 



 
 

A new, unformatted shapefile of the rivers in your area of interest will be added to the Layers 
Panel and Map View. 

 Copy and paste the symbology from the old shapefile to the new version. 
 Remove the old shapefile. 

 



 
 

Finally, to automatically measure the distances we need to install a “Plugin” – an extra tool that 
is not part of the main QGIS software but which runs inside it. 

 On the Menu click “Plugins” > “Manage and install plugins”. 
 Click the All tab. 
 Type “nnjoin” into the search box. 
 Click “NNJoin” and then Install Plugin and then Close when it completes. 

 

 On the Menu click “Vector” > “NNJoin” > “NNJoin”. 

 



 
 

 For “Input vector layer” select your sites shapefile. 
 For “Join vector layer” select the HydroRIVERS shapefile. 
 For “Output layer” give your new file a useful name then click OK and Close when 

finished. 

 

A new layer will be added to QGIS. 

 Open the new layer’s Attribute Table. 

You will notice that as well as elevation, it now also contains all the details of the closest river to 
each site including, in the last column, the distance between them, in metres. 

 



 
 

The NNJoin plugin works a little bit differently to other tools – it doesn’t save the results 
permanently, so we have to tell it to do this.  

 If you look next to your new sites layer you will see a little computer chip icon – this tells 
us that it is a temporary file. 

 

 Right-click this file and select “Make Permanent”. 
 Save it as a shapefile in your Geospatial folder with the other files. 



 
 

Just as with elevation we can show the distance of each site to its nearest river on our map. 

 Right-click your new shapefile and select “Properties”. 
 Click on the Symbology tab and change “Single symbol” to “Graduated”. 
 Change “Value” to “distance” (right at the bottom of the list). 
 Choose a suitable colour ramp. 
 If you increase the number of classes more variation in the colours will become visible. 

 



 
 

These will now be visible on your map. 

 

 

2.3 Using filtering to analyse different groups of sites (video tutorial) 

Now that we have all of this new geospatial information about our sites, we want to be able to 
use it to better understand them. We are going to do this by asking and answering our own 
questions about the sites using filtering and statistics in QGIS. 

For my example I am going to ask two questions about my data: 

 1) Are Roman religious sites located in higher positions than other Roman sites?  

2) Are Roman settlements located closer to rivers and streams than other Roman sites?  

You will need to come up with your own questions, but these are two good examples to 
demonstrate the general method. 



 
 

We are going to create two new fields in our attribute table, “Religious” and “Settlement”, to 
mark the relevant records. 

 Right-click the sites shapefile and select “Open Attribute Table”. 
 Click the filter “Show All Features” button. 
 Select “Field Filter” > “Function”. 
 In the bottom box type “Religious” and press enter. 

 



 
 

You will see that the attribute table now only includes 17 records that contain the word 
“Religious” in the “Function” field. 

 

We now want to mark these sites so we can easily find them again more easily. We will do this 
by creating a new field. 

 Select all 17 “Religious” sites by selecting the row number next to the first, holding shift, 
and selecting the row number next to the last site. 

 Then click the “Field Calculator” button. 

 



 
 

 In the Field Calculator type “Religious” for “Output field name” 
 Change “Output field type” to “Text (string)”. 
 Type “ ‘Religious’ ”  into the “Expression” box (you must include the single quotes). 
 Click OK. 

 



 
 

If you scroll to the last column in the Attribute Table, you will see that it is now the “Religious” 
column and that all the sites within it have the same label. 

 

 Click the Filter “Function” button and select “Show All Features” 

 

You will see that only the fields you selected have the “Religious” label. 



 
 

We now want to repeat this process for settlement sites. 

 Click the Filter “Show All Features” button and select “Field Filter” > “Interpreta[tion]”. 
 Type “Settlement” in the bottom box and press the Enter key. 
 Select all the filtered records using the Shift key. 
 Click the “Field Calculator” button. 
 Create a “Settlement” text field. 
 Type “ ‘Settlement’ ” into the “Expression” box and click OK. 

 



 
 

 Click the Filter “Interpreta[tion]” button and select “Show All Features”. 
 Click the “Edit” button to turn editing off. 
 Click the “Deselect all” button to clear the selection. 

 

If you scroll to the right you will see that you now have two new fields with “Religious” and 
“Settlement” sites marked separately. 

 



 
 

We are now going to calculate some statistics based on these two fields to try and answer our 
questions. 

 On the Menu select “Processing” > “Toolbox”. 
 Expand “Vector analysis” and double-click on “Statistics by categories”. 

 

 Select your sites shapefile for “Input vector layer”. 
 For “Field to calculate statistics on” select “Elevation”. 
 For “Fields with categories” select “Religious”. 
 Click Run. 

 



 
 

A new table will be added to the Layers Panel. 

 Right-click this table and select “Open Attribute Table”. 

 

You will see that statistics have been calculated on the elevation of religious sites and non-
religious sites.  

We are most interested in the mean and median statistics. 

 The ‘mean’ value is the average elevation of the sites in that group. 
 The ‘median’ value is the middle value in the list of the elevations in that group. 

In this case, both the mean and the median elevations are considerably higher for religious sites 
than the non-religious (NULL) sites. This helps us to answer the question of whether or not 
Roman religious sites are higher than other Roman sites: Roman religious sites are, on average, 
located at higher elevations than other Roman sites. 

Now we are going to use the same method to answer our second question. 

 Double-click again on “Statistics by categories” in the Processing Toolbox. 
 Select your sites shapefile for “Input vector layer”. 
 For “Field to calculate statistics on” select “Distance”. 
 For “Fields with categories” select “Settlement”. 
 Click Run. 
 Right-click the new table and select “Open Attribute Table”. 

 

Notice that both the mean and median values for Settlement sites are considerably higher than 
for non-settlement (NULL) sites. Therefore, we can conclude that our Roman settlement sites 
are closer to river channels on average than non-settlement sites! 



 
 

If we want to keep our results we need to save them. 

 Right-click the newest table and select “Make permanent”. 
 For file-type select “MS Office Open XML Spreadsheet”. 
 Click the Browse button […] and save it in the Geospatial folder and click OK. 

 

 Repeat for the other table 

You can now also open these files in Excel or other spreadsheet software if you want. 

 

PRACTICE: use this method to calculate the average upstream catchment area for a site 
category of your choice. 

 

ACTIVITY: set yourself some questions relating to elevation and/or hydrology from your data 
and answer them using these simple geospatial analyses. 


